Script DynDNS OVH avec Mikrotik

Créer un utilisateur DynDNS chez OVH

Se connecter avec le manager sur l’espace web et sélectionner son domaine :

 

2015-11-07-19_04_02.png

Se rendre dans l’onglet DynHost et ajouter un DynHost :

2015-11-07-19_07_57

Cliquer ensuite sur le bouton « Gérer les accès » , toujours dans DynHost et créer un nouvel identifiant :

2015-11-07-19_06_14.png

Script Mikrotik

Se connecter sur la console du Mikrotik et créer un script « dynDns » avec le contenu suivant :

# Define User Variables
:global ddnsuser "[à compléter]"
:global ddnspass "[à compléter]"
:global ddnshost "[à compléter]"
:global ddnserver "www.ovh.com"

# Define Global Variables
:global ddnsip
:global ddnslastip

# Grab the current IP address
/tool fetch url="http://myip.dnsomatic.com/" mode=http dst-path=mypublicip.txt
:global ddnsip [/file get mypublicip.txt content]

# Did we get an IP address to compare?
:if ($ddnsip != $ddnslastip) do={
    :log info "DynDNS: Sending UPDATE!";
    :local str "/nic/update3Fsystem=dyndns&hostname=$ddnshost&myip=$ddnsip";
    /tool fetch address=$ddnserver host=$ddnserver src-path=$str dst-path=("/DynDNS.".$ddnshost) mode=http user=$ddnsuser password=$ddnspass;
    :global ddnslastip "$ddnsip";
}

Remplacer le 1er [à compléter] par votre nom d’utilisateur DynHost, le second par son mot de passe et le troisième par le (sous-)domaine DynHost.

Je précise que ce script est inspiré de http://wiki.mikrotik.com/wiki/Dynamic_DNS_Update_Script_for_dynDNS, d’où les commentaires en anglais 🙂

Scheduler

Il faut à présent l’exécuter régulièrement pour toujours maintenir l’IP DynHost à jour avec un job à créer dans le scheduler :

2015-11-07-19_12_27

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s